Forums  
  Discussion  
    Tim's Web Quiz  
    Tim's Web Puzzles  
  Polls - Freshwater  
  Polls - Saltwater  
   





 

Go Back   Tropical Fish Forum . Net > General Aquarium Care > Plants

Plants Questions and comments about freshwater plants

 
 
Thread Tools Search this Thread Display Modes
  #11  
Old ,
Dano's Avatar
Dano Dano is offline
Senior Member
 
Join Date: Oct 2007
Location: Goose Creek SC USA
Posts: 1,892
Default Re: Plants aren't working well...

Flourite eco complete?? For a low maintenance, low tech beginner plant tank you don't need it... A plain old fluorescent tube of 15 to 25 watts on a 10 gallon tank works great. The plants I listed were good for starters and are probably more available. No vallisneria in a beginner tank! A little fertilizer and a light schedule of about 8 hours is good for starters. My post was directed to a young person wanting to start simple and being a student won't allow a lot of time to experiment with more complicated plants or equipment.( probably only gets a couple hundred bucks a week allowance also )
  #12  
Old ,
Pwat's Avatar
Pwat Pwat is offline
Senior Member
 
Join Date: Mar 2008
Location: Maryland
Posts: 328
Default Re: Plants aren't working well...

I don't even get any allowance and yes i don't have much time! Thanks Dano, i didn't look for a day at this forum and it grew all popular lol.

To the point though, my gravel is around 1 1/2 inches and about 1/4 of an inch across. I was thinking of getting Java fern, i've wanted to get it for awhile now, I just have to verify with my LFS if they have any before i go. I'm planning on putting java fern in both of my tanks.

So should i get fertilizer? Everyone confused me lol. And what type is the best and cheapest?
__________________
10 gallon: Female Cambodian Betta, 2 cories
20 gallon: planning to put some livebearers
Outside Pond: empty for the winter
"Speak your mind, even if your voice shakes."
-Maggie Kuhn
  #13  
Old ,
Dano's Avatar
Dano Dano is offline
Senior Member
 
Join Date: Oct 2007
Location: Goose Creek SC USA
Posts: 1,892
Default Re: Plants aren't working well...

I use Flourish, but there are several that are just as good. Don't do root tabs yet. The Java Ferns have been a finicky plant with me, but everyone swears by them. You might want to google it for more details. I partially covered the roots and nada! I have one with the rootie part wedged in a crack in my driftwood and it seems to like it there so far. As you can see from my many posts that I recommend researching everything. (Googleing) It is a good habit and you learn more than just accepting what other people say.
  #14  
Old ,
alan j t's Avatar
alan j t alan j t is offline
Senior Member
 
Join Date: Aug 2008
Location: reno nv
Posts: 151
Default Re: Plants aren't working well...

Quote:
Originally Posted by Pwat View Post
I don't even get any allowance and yes i don't have much time! Thanks Dano, i didn't look for a day at this forum and it grew all popular lol.

To the point though, my gravel is around 1 1/2 inches and about 1/4 of an inch across. I was thinking of getting Java fern, i've wanted to get it for awhile now, I just have to verify with my LFS if they have any before i go. I'm planning on putting java fern in both of my tanks.

So should i get fertilizer? Everyone confused me lol. And what type is the best and cheapest?
oops sorry pwat
i was under the assumption you were going to be a plant person
since time and money is an issue i would go with anubias
javafern is a pita for me aswell
you dont have to plant anubias and is a lowlight lovin plant
dont forget to change your bulb out when they get a year old

heres that plant in the pot idea,if n when you chose to upgrade or advance in planthood
http://i290.photobucket.com/albums/l...of100_1543.jpg
  #15  
Old ,
Dano's Avatar
Dano Dano is offline
Senior Member
 
Join Date: Oct 2007
Location: Goose Creek SC USA
Posts: 1,892
Default Re: Plants aren't working well...

Alan Is that your 150 with the discus and potted swords?
  #16  
Old ,
alan j t's Avatar
alan j t alan j t is offline
Senior Member
 
Join Date: Aug 2008
Location: reno nv
Posts: 151
Default Re: Plants aren't working well...

no its not a 150,my wife wouldn't let me get the big one because that would mean to upgrade lights and filters aswell
its an 80 and doesnt need upgrading lights and such
i know its overstocked
but i maintain water cond.
i see myself as a waste managment reclamation spaecialist j/k

Last edited by alan j t : at .
  #17  
Old ,
Dano's Avatar
Dano Dano is offline
Senior Member
 
Join Date: Oct 2007
Location: Goose Creek SC USA
Posts: 1,892
Default Re: Plants aren't working well...

It looks good! It sure looks like my 6 foot 150. What are the dimensions of the tank because it sure looks bigger than the 75s that I have. (4 footers)
  #18  
Old ,
Dano's Avatar
Dano Dano is offline
Senior Member
 
Join Date: Oct 2007
Location: Goose Creek SC USA
Posts: 1,892
Default Re: Plants aren't working well...

PS: The PetSmart near me has a bunch of great looking Java Fern plants for like $3 bucks ea. I don't know if you are near a PetSmart, but they seem to always have reasonable plants.
  #19  
Old ,
alan j t's Avatar
alan j t alan j t is offline
Senior Member
 
Join Date: Aug 2008
Location: reno nv
Posts: 151
Default Re: Plants aren't working well...

its a 4 footer
i guess it is a 75
  #20  
Old ,
Dano's Avatar
Dano Dano is offline
Senior Member
 
Join Date: Oct 2007
Location: Goose Creek SC USA
Posts: 1,892
Default Re: Plants aren't working well...

Sure looks bigger than that to me. What is the lxwxh?
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is .


Powered by vBulletin Version 3.6.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.